Qbee-X for A10 (ubuntu 12, nand.img + sd.img, working full-hd, multi DE)

Started by Tokka, February 09, 2014, 11:50:35 am

Previous topic - Next topic

Tokka

Based on ubuntu 12.04 Precise LTS, Qbee-X is a new (or better...another ;D) image for cb1.

user/password are:

cubie/cubie

root/root

as always, is suggested to change the default password ;)


see above for "what's new"

                  =========== TMC Final Release ============

28/05/15


  • removed gnome and xfce4


  • upgraded ffmpeg to 2.6.3

  • upgraded smplayer and smtube

  • added ajenti for remote control (address is https://your_cubie_ip:8000, user: root, pass: admin)

  • added couchpotato to manage torrents search and download

  • changed transmission with deluge (empty password for remote connections) for better performances and better integration with couchpotato



nand image

uSD image (note: image is 3.5gb, so don't forget to resize it after install)
seems that torrents have some troubles :(

uSD

nand



                     ========== TMC EDITION ===============                       

New: QBee-X_TMC is online

here more infos and dl files.

In short:

- added xbmc 12.2 with full-hd woking, and mp3 not working :( ;

- added madsonic as mediaserver and for remote streaming;

- upgraded smplayer, smtube, ffmpeg, lame and h264 to the latest version.

- changed default desktop from gnome to lxde.

====================================================

Download links:  

Nand version (make a backup of your nand before!!)   tar -xzf Qbee-X_nand.img.tar.gz    and after   sudo dd if=Qbee-X_nand.img of=/dev/nand
md5:
cca7e0b031f538ce75de08ec6cbdc880  Qbee-X_nand.img.tar.gz
6d66f2b8181b81bdf63df2ebbd019654  Qbee-X_nand.img


SD version:   tar -xzf Qbee-X_A10.img.tar.gz     and after     sudo dd if=Qbee-X_A10.img of=/dev/mmcblk0 bs=1M
md5:
a159cfd5b8fc85fb153882c858e2ab42  Qbee-X_A10.img.tar.gz
3e75ea8438878f5c816506abac7163e0  Qbee-X_A10.img


SD -resized- version: no more needed and without last changes, but i'll keep the link up for a couple of weeks
(same as the one before, but without the "extra size" error (thanks Ikeeki :-*))
unzip Qbee-X_A10.img.zip      and after     sudo dd if=Qbee-X_A10.img of=/dev/mmcblk0 bs=1M
md5: 2fa833de415639ce933509ea299a6bdf  Qbee-X_A10.img.zip   
use this form the moment, and boot with the hdmi cable unplugged, remove the EDID from uEnv.txt in boot partition, and after you can boot without unpluggin the cable

Features:

kernel: 3.4.79 by Patwood

Desktop, you can choose between:
- gnome (set as default, with remote desktop enabled without password, you can disable it from applications - internet- desktop sharing);



- lxde



- xfce (when you logout from gnome and choose the DE you want, xfce is under the virtual keyboard, so you have to close it to see xfce in the menu...sorry  :-[)



Browsers:
- firefox
- chromium
both have youtube enabled, but it no works well (360p), and vimeo don't works  :-\

- smplayer: works with sd, hd, and full-hd movies (and audo files too)
- smtube: to watch youtube videos with smplayer (now at 1080)

- mplayer: for full hd movies (still present, but no more needed)

- mediatomb: media-server/dlna-server, to stream music, videos and images over your network (and the net, if you want). Should works with Lg dlna tv too, but i haven't, so not tested

- power-buton: if pushed, it open the reboot-suspend-shutdown window (but i think only with gnome :P)

- network: managed by network-manager (wired too), and set to dhcp

- cifs-mount installed (not pre-configured)

- x11vnc installed (not pre-configured)

- ubuntu-tweak installed, to have some nice tricks, as clean-up the system :P

- Tools folder (in /home/cubie): remote-desktop script (usefull if you use lxde or xfce - no password preset - ); sunxi-tools (for some customization); nandinstall (not totaly works with this version, sorry).

- Leds:
sd-card version: blue led for sd, green led for sda (you can change/disable by commenting the related lines in /etc/rc.local)
nand-version: blue led for cpu activity, green led for mmc

- cpu: overclocked at 1.17 ghz

- xbmc: not installed at the moment, i'm planning to recompile it with full hd support

- upgrade-manager: installed and working (no issues found at the moment, in case report here)

- others: .....don't remember   ;D ;D



a GREAT thanks to Ikeeki, Patwood, Ssvb, and all the forum's members who wrote most of the tricks i used in this version.
A special thanks to Ikeeki for support, tricks, tests, port this version on A20 (with the holy-hand of Pat  ;D), and overall the tons of laught we made together...it's a real pleasure work with you  :-* :-* ;D ;D ;D ;D ;D ;D ;D


Cheers
Tk
CB1 (A10) - Qbee-X_TMC

ikeeki

It's been a pain in the ass pleasure, and we expect to be able to release a CB2 CT version (lots of work, people needed).
The .img works flawslesly and makes cubie 1 seem to be a bit superior hardware than it's been until now.

Thanks Tokka and Forza¡¡¡

QBEEEEEEEEEEEEEEEEEEEEE-X ¡¡¡¡¡

Tokka

LOOOOOLLLLLLLL
that's true.....a very pain in the assleasure  :-\ ;D ;D
You know, my intent is to do an all in one version, for all cubies...but i have only cb1, so i have to sacrifice yours  8) ;D ;D ;D ;D ;D ;D
CB1 (A10) - Qbee-X_TMC

Laffer

I put the SD image to the SD card, but it is not working. I have connected a SATA Drive (not yet mounted), DELL mouse and USB keyboard...

See pics for error messages.



Laffer


Tokka

Ok, one step for time  ;D
Which img have you downloaded?
Have you had some error message writing it?
CB1 (A10) - Qbee-X_TMC

Laffer

I used this link: http://dl.cubieforums.com/ikeeki/IMAGES/tk/Qbee-X_A10.img.tar.gz

I unpacked it with 7zip on windows.

I wrote the img file with Win32DiskImager to the SD Card. No error message.

Tokka

ok, make a try.
Use this file: http://dl.cubieforums.com/ikeeki/IMAGES/tk/Qbee-X_A10.img.zip
and after wrote the img, start the cubie without the hdmi cable connected; when you see the green led, plug the hdmi cable

i forgot: which windows version do you have?
CB1 (A10) - Qbee-X_TMC

Laffer

This one worked. It booted into a desktop. I did connect HDMI late. Why do I need to connect late?

Tokka

Because there is the EDID parameter into uEnv.txt wich crash the boot process.
If you are logged in now, remove it:
change in the extraargs from disp.screen0_output_mode=EDID:5
to
disp.screen0_output_mode=5
In this way you can boot without removing the hdmi cable
CB1 (A10) - Qbee-X_TMC

Laffer

Quote from: Tokka on February 11, 2014, 02:14:02 pm
Because there is the EDID parameter into uEnv.txt wich crash the boot process.
If you are logged in now, remove it:
change in the extraargs from disp.screen0_output_mode=EDID:5
to
disp.screen0_output_mode=5
In this way you can boot without removing the hdmi cable


Cool... Now I will try to move the rootfs to SATA...  following this guide: http://docs.cubieboard.org/tutorials/ct1/installation/moving_rootfs_from_nandflash_to_hard_drive

Tokka

simple way:
dd if=/dev/mmcblk0p2 of=/dev/sda1 bs=1M

and add to uEnv.txt root=/dev/sda1, as explained in the uEnv file
;)
CB1 (A10) - Qbee-X_TMC

Laffer

root@Qbee-X:~# df
Filesystem     1K-blocks    Used Available Use% Mounted on
rootfs           3023760 2376028    494132  83% /
/dev/root        3023760 2376028    494132  83% /
devtmpfs          415040       4    415036   1% /dev
none               83032     616     82416   1% /run
none                5120       0      5120   0% /run/lock
none              415144      76    415068   1% /run/shm
/dev/mmcblk0p2   3023760 2375696    494464  83% /media/Qbee-X
/dev/mmcblk0p1     20422    4882     15540  24% /media/BOOT_SD


It is shown double or triple...

bootargs=console=tty0 sunxi_fb_mem_reserve=64 mac_addr=02:00:02:t0:kk:40
extraargs=consoleblank=0 disp.screen0_output_mode=5 rootwait panic=10 rootfstype=ext4 rootflags=discard
nand_root=/dev/sda2
root=/dev/sda2


I also tried only with root= or only with nand_root=