November 21, 2019, 06:24:52 pm

News:

Have you visited the Allwinner Chipset wiki? - http://linux-sunxi.org/


glmark2-es2 - failed to open sunxi-mali

Started by Jojo, January 23, 2014, 09:02:03 am

Previous topic - Next topic

Jojo

Hello,

I just tried this nice thing glmark2-es2. But when started, it says:


linaro@linaro-ubuntu-desktop:~$ glmark2-es2
libEGL warning: failed to create a pipe screen for sunxi-mali
libEGL warning: DRI2: failed to open sunxi-mali (search paths /usr/lib/arm-linux-gnueabihf/dri)
.
.
.


And the results are quite bad. If that means that my mali-driver is not running correctly, what can I do?!

lsmod says:

linaro@linaro-ubuntu-desktop:~$ lsmod
Module                  Size  Used by
disp_ump                 861  0
8192cu                450521  0
mali_drm                2608  1
drm                   208605  2 mali_drm
mali                  110943  0
ump                    51995  4 disp_ump,mali
lcd                     3778  0


I am running cubiuntu 0.6 from patwood on CB2.

Greetings,
Jojo
Don't think that anyone will take more pains for his answer, as you took for your question.

ikeeki

http://linux-sunxi.org/Binary_drivers
Check that  ;)

BTW, cubiuntu and others had it installed and working.

Jojo

Hello,

thanks for the answer!

Quote from: ikeeki on January 23, 2014, 09:10:47 am
http://linux-sunxi.org/Binary_drivers
Check that  ;)

BTW, cubiuntu and others had it installed and working.


Yes, I know that site. But I didn'n want to install things blindly, just because they matched me google request ;) .
I also thought/knew, that these drivers are preinstalled in cubiuntu, but, what can I say? They don't work :( . But maybe I damaged something during installation of other things...

But would you say, that a reinstallation like here
http://linux-sunxi.org/Binary_drivers
could be a solution?

Greetings
Don't think that anyone will take more pains for his answer, as you took for your question.

ikeeki

In short a new version of cubiuntu/X will be released with maaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaany things working, but in any case I do swear the instructions of that page are fully working when correctly followed. In fact is kind of the bible for the cubie fans (as me)

Jojo

Hello,

ok, the instructions on the website did not work :( . But after you have promised a new cubiuntu release I think I'm gonna wait and overwrite my current OS.

Thanks and I am curious about the new release :) !
Don't think that anyone will take more pains for his answer, as you took for your question.

patwood

Specifically, read this part: http://linux-sunxi.org/Binary_drivers#Mesa_libraries_are_still_in_the_way

It mentions the exact messages you're seeing and the proper solution.

glmark2-es2 should work just fine out-of-the-box, and does on my CB with a fresh install.  If you do an "apt-get upgrade", you'll certainly get a new mesa-egl installed, which will need to be renamed again.

Jojo

Ok shame over me...  :-[

The hint from Patrick was the key. When I did

mv /usr/lib/arm-linux-gnueabihf/mesa-egl/ /usr/lib/arm-linux-gnueabihf/.mesa-egl/

the first time, it told me that some "folders are not empty". So I decided to delete the already existing folder and just renamed the folder, that should be moved like in the command above.

When I ran glmark2-es2 I got a score of 156 and the tests looked quite beautyful.

But there are still not the "FBTURBO"-entries in the xorg.0.log. Is that something to worry about?

Thanks!
Don't think that anyone will take more pains for his answer, as you took for your question.

patwood

It's an older distro with an older driver called xf86-video-sunxifb before the name was changed to fbturbo.

ikeeki

January 25, 2014, 08:00:27 am #8 Last Edit: January 25, 2014, 08:23:35 am by ikeeki
http://www.cubieforums.com/index.php/topic,362.0.html
172 global score.
That's provisional, but works really well, until we have the next one ready  ;)