Author Topic: Ubuntu 12.04 LTS + Mali400  (Read 30958 times)

Offline Delectable

  • Newbie
  • *
  • Posts: 21
  • Karma: +2/-0
    • View Profile
Ubuntu 12.04 LTS + Mali400
« on: February 24, 2013, 05:28:17 pm »
Hi guys,

Just to help new users out, here's a copy of my cubie 1GB image. It contains the following:

  • 1GB memory support
  • >5GB SD card required
  • Mali400 drivers installed (R3P0), working but issues with chmod
  • Latest HWpack used
  • CPU tweaked and working
  • Mali working on framebuffer, not X11

Just install the image and chmod 777 the /dev/mali and /dev/ump and Mali400 should work out of the box. Hope you guys enjoy and if there are issues please let me know  :D.

Ubuntu 12.04 LTS + Lima400 (Download)
« Last Edit: March 03, 2013, 11:52:05 am by Delectable »

Offline lawrence

  • Administrator
  • Sr. Member
  • *****
  • Posts: 300
  • Karma: +15/-0
    • View Profile
Re: Ubuntu 12.04 LTS + Lima400
« Reply #1 on: February 25, 2013, 12:25:36 am »
You may want to make a split version as well, with rootfs + kernel under /boot in case people want as a tar rather than an image.

I can split it out if necessary though.

Thanks for uploading!

Offline GeorgeIoak

  • Jr. Member
  • **
  • Posts: 52
  • Karma: +1/-0
    • View Profile
Re: Ubuntu 12.04 LTS + Lima400
« Reply #2 on: February 25, 2013, 10:15:19 pm »
Is the Lima400 driver working for general video decoding or do you have to compile your "video player" specifically for Lima400 usage?

90dfr3y

  • Guest
Re: Ubuntu 12.04 LTS + Lima400
« Reply #3 on: February 25, 2013, 11:13:40 pm »
Thanks for sharing.
But can you please zip the image file?

Offline lawrence

  • Administrator
  • Sr. Member
  • *****
  • Posts: 300
  • Karma: +15/-0
    • View Profile
Re: Ubuntu 12.04 LTS + Lima400
« Reply #4 on: February 26, 2013, 05:42:24 am »
I have zipped it (bzip2)

Offline Delectable

  • Newbie
  • *
  • Posts: 21
  • Karma: +2/-0
    • View Profile
Re: Ubuntu 12.04 LTS + Lima400
« Reply #5 on: February 26, 2013, 03:21:27 pm »
Is the Lima400 driver working for general video decoding or do you have to compile your "video player" specifically for Lima400 usage?
It's working for general video decoding

90dfr3y

  • Guest
Re: Ubuntu 12.04 LTS + Lima400
« Reply #6 on: February 26, 2013, 11:12:08 pm »
Thanks a lot lawrence. Downloading now....
I will try this on weekend :-)

I have zipped it (bzip2)

RomanNV

  • Guest
Re: Ubuntu 12.04 LTS + Lima400
« Reply #7 on: February 27, 2013, 01:05:05 am »
Just install the image and chmod 777 the /dev/lima and /dev/ump and Lima400 should work out of the box.
Hello!
Is it needs to be done each time, or in the first starting only?
« Last Edit: February 27, 2013, 01:06:40 am by RomanNV »

Offline Delectable

  • Newbie
  • *
  • Posts: 21
  • Karma: +2/-0
    • View Profile
Re: Ubuntu 12.04 LTS + Lima400
« Reply #8 on: February 28, 2013, 08:19:11 am »
Just install the image and chmod 777 the /dev/lima and /dev/ump and Lima400 should work out of the box.
Hello!
Is it needs to be done each time, or in the first starting only?
For NOS it needs to be done everytime. I was having issues booting when automating the process. The next release will adres this issue.

RomanNV

  • Guest
Re: Ubuntu 12.04 LTS + Lima400
« Reply #9 on: February 28, 2013, 11:12:23 am »
When I try to "chmod 777 /dev/lima" I have the msg:
chmod: cannot access `/dev/lima': No such file or directory
Is lima correct name? I have mali in /dev/ but have not lima.
ump is Ok.

Offline galiclick

  • Newbie
  • *
  • Posts: 3
  • Karma: +0/-0
    • View Profile
Re: Ubuntu 12.04 LTS + Lima400
« Reply #10 on: February 28, 2013, 06:42:34 pm »
can please describe the steps to create the image, I want to create an image of ubuntu server.


Thank you so much.

Offline OmahaVike

  • Newbie
  • *
  • Posts: 15
  • Karma: +0/-0
    • View Profile
Re: Ubuntu 12.04 LTS + Lima400
« Reply #11 on: March 01, 2013, 09:15:53 am »
can please describe the steps to create the image, I want to create an image of ubuntu server.

If you do choose to make an image of ubuntu server, be sure to include the performance tweak in rc.local outlined here (is this a good practice, anyone?):

http://www.cubieforums.com/index.php/topic,24.msg76.html#msg76

I noticed that the linaro server image has the ondemand compiler built in, but need to add the stuff in "#If you wanted to use performance, which is more appropriate for a desktop change that below, and uncomment out the appropriate line.". 

Also, the quantal image didn't work for me, but the precise one worked fine.  Just a tip/trick to help you along.

90dfr3y

  • Guest
Re: Ubuntu 12.04 LTS + Mali400
« Reply #12 on: March 06, 2013, 04:08:31 am »
Hi,

I tried the image last weekend, but my monitor does not show the whole screen, it seems to exceed the monitor's display. Are there any settings that I need to change to have it displayed correctly?
I have also a RaspberryPi, and what I did is to change the overscan settings. Are there any similar settings in Cubieboard?
Also, is the SSHd enabled by default on this image? What is the default login?

Thank you in advance for any of your help!

Offline nevilles

  • Newbie
  • *
  • Posts: 8
  • Karma: +0/-0
    • View Profile
Re: Ubuntu 12.04 LTS + Mali400
« Reply #13 on: March 20, 2013, 04:14:37 am »
Used the image on my new cubieboard - awsome!!

Any chance of getting hold of the .config file you used to build your kernel with?

Offline lawrence

  • Administrator
  • Sr. Member
  • *****
  • Posts: 300
  • Karma: +15/-0
    • View Profile
Re: Ubuntu 12.04 LTS + Mali400
« Reply #14 on: March 20, 2013, 07:22:14 am »
To see the config used:

Code: [Select]
zcat /proc/config.gz 
or

Code: [Select]
zcat /proc/config.gz > somefile.txt