November 15, 2019, 11:27:47 am

News:

Have you visited the Allwinner Chipset wiki? - http://linux-sunxi.org/


Can't capture audio from Line-In

Started by visiCubie, January 08, 2014, 10:34:09 am

Previous topic - Next topic

visiCubie

I'm trying to use the Line-In of the Cubieboard v1 to capture some audio. So far without success :(

I'm using the current Cubian image (Cubian-base-r7-arm-a10). The sound device looks ok to me.
There is only the sunxicodec soundcard (hdmi is disabled) and within the alsamixer I can configure the diferent parameters.
Playback with aplay works ok, but recording with arecord generates always a file with silence.

I tried it with a lot of different settings in the mixer but with no success.
I've also tried an diffrent OS (berryboot with debian) with no success.
I've also tried this on two different boards with no success.

I have no further ideas how to get it working.
Any clues what I can check or try to get some recording?
What are the correct settings in alsamixer to capture from line-in?
Are there some low-level tools I can use to check if the hardware is ok?

Or does someone have any other clues what I can do?

tista

I had this problem too. I got it Line In to work by installing pulseaudio.


$ sudo apt-get install pulseaudio