Author Topic: Cubiuntu 0.6 for A20 with 3.4.75+ kernel  (Read 53705 times)

Offline patwood

  • Linux geek
  • Global Moderator
  • Hero Member
  • *****
  • Posts: 1660
  • Karma: +129/-0
    • View Profile
Re: Cubiuntu 0.6 for A20 with 3.4.75+ kernel
« Reply #15 on: January 03, 2014, 12:13:41 am »
Update is fine, but I do not recommend upgrade as sometimes a20 specific code is overwritten by the upgrade.

ikeeki

  • Guest
Re: Cubiuntu 0.6 for A20 with 3.4.75+ kernel
« Reply #16 on: January 03, 2014, 05:13:49 pm »
Hi, can anybody confirm if the download is correct?
I've tried to download it and uncompress the xz file but no luck (error in the middle)  :o

Offline patwood

  • Linux geek
  • Global Moderator
  • Hero Member
  • *****
  • Posts: 1660
  • Karma: +129/-0
    • View Profile
Re: Cubiuntu 0.6 for A20 with 3.4.75+ kernel
« Reply #17 on: January 03, 2014, 06:20:48 pm »
Hi, can anybody confirm if the download is correct?
I've tried to download it and uncompress the xz file but no luck (error in the middle)  :o

I just downloaded it to another directory and compared it with my original upload file. Then I did

xzcat -t < Cubiuntu0.6.5b-a20.img.xz

with no errors.  Is your md5 the same?

ikeeki

  • Guest
Re: Cubiuntu 0.6 for A20 with 3.4.75+ kernel
« Reply #18 on: January 03, 2014, 06:31:54 pm »
root@ikeeki-Extensa-5635Z:/home/ikeeki# md5sum '/home/ikeeki/Escritorio/Cubiuntu0.6.5b-a20.img.xz'
994133991092ca09a1d0e9e44ed31353

But it gives me error with my standard fileroller...

Edit: checking with command line

Edit:
root@ikeeki-Extensa-5635Z:/home/ikeeki/Escritorio# xz -d Cubiuntu0.6.5b-a20.img.xz

with command line works, sorry for waste your time, I'm look into the fileroller problem  :-[ :-[ :-[
« Last Edit: January 03, 2014, 06:47:09 pm by ikeeki »

ikeeki

  • Guest
Re: Cubiuntu 0.6 for A20 with 3.4.75+ kernel
« Reply #19 on: January 03, 2014, 08:45:37 pm »
Works, really well, I thought that the glmark-es2 and gears were going to be faster, but the 1080p video runs quite smoothly (60hz). A simple video player would be very nice to make a quite acceptable desktop.

Thanks again, I'll try to follow these improvements.

Offline totalguy

  • Full Member
  • ***
  • Posts: 114
  • Karma: +2/-0
    • View Profile
Re: Cubiuntu 0.6 for A20 with 3.4.75+ kernel
« Reply #20 on: January 05, 2014, 08:58:16 am »
im having a problem with my tv on this image (and debian)

although this image sees the resolution of my tv correctly 1920 x 1080 but the desktop and any windows i open are off screen so its difficult to work with. how do i correct this ?

just to add to this if i plug my cubieboard into an older lcd tv it shows everything perfect and its running on 13xx x 768.
« Last Edit: January 05, 2014, 09:11:17 am by totalguy »

Offline patwood

  • Linux geek
  • Global Moderator
  • Hero Member
  • *****
  • Posts: 1660
  • Karma: +129/-0
    • View Profile
Re: Cubiuntu 0.6 for A20 with 3.4.75+ kernel
« Reply #21 on: January 05, 2014, 12:32:54 pm »
im having a problem with my tv on this image (and debian)

although this image sees the resolution of my tv correctly 1920 x 1080 but the desktop and any windows i open are off screen so its difficult to work with. how do i correct this ?

just to add to this if i plug my cubieboard into an older lcd tv it shows everything perfect and its running on 13xx x 768.

It may not be reading the HDMI EDID properly.  On the first partition (FAT), there's a file called uEnv.txt.  Try playing around with the disp.screen0_output_mode setting, e.g., change it from

disp.screen0_output_mode=EDID:1280x720p60

to

disp.screen0_output_mode=1920x1080p60

or

disp.screen0_output_mode=1920x1080p50

By removing the EDID:, you will prevent the kernel from using the value returned from the monitor before falling back to the hard-coded value.

Offline totalguy

  • Full Member
  • ***
  • Posts: 114
  • Karma: +2/-0
    • View Profile
Re: Cubiuntu 0.6 for A20 with 3.4.75+ kernel
« Reply #22 on: January 05, 2014, 12:57:28 pm »
thanks that has helped somewhat, at the moment it runs best on this setting

disp.screen0_output_mode=1280x720p60

but its still not quite there as there is a slight bit around the edges still off screen.

i tried 1920x1080p60 and p50 it was worse on 50 and i tried 50 on the lower resolution that was worse.

the right hand size of the screen is fine its the top the left and the bottom slightly off. but ive had this problem on another tv before using windows and the tv but there you can use a GUI to change resolution as on here you can not

Offline manu314

  • Newbie
  • *
  • Posts: 11
  • Karma: +0/-0
    • View Profile
Re: Cubiuntu 0.6 for A20 with 3.4.75+ kernel
« Reply #23 on: January 11, 2014, 06:12:25 pm »
Dear All,

Is there anything to do to activate the audio on the standard line output ?
Neitheir aplay not mplayer manage to initialize audio

see
/home/linaro# mplayer M1F1-int16WE-AFsp.wav
MPlayer svn r34540 (Ubuntu), built with gcc-4.6 (C) 2000-2012 MPlayer Team
mplayer: could not connect to socket
mplayer: No such file or directory
Failed to open LIRC support. You will not be able to use your remote control.

Playing M1F1-int16WE-AFsp.wav.
libavformat version 53.21.1 (external)
Mismatching header version 53.19.0
Audio only file format detected.
Load subtitles in ./
==========================================================================
Opening audio decoder: [pcm] Uncompressed PCM audio decoder
AUDIO: 8000 Hz, 2 ch, s16le, 256.0 kbit/100.00% (ratio: 32000->32000)
Selected audio codec: [pcm] afm: pcm (Uncompressed PCM)
==========================================================================
AO: [pulse] Init failed: Connection refused
Failed to initialize audio driver 'pulse'
[AO_ALSA] Playback open error: No such file or directory
Failed to initialize audio driver 'alsa'
[AO SDL] Samplerate: 8000Hz Channels: Stereo Format s16le
[AO SDL] using aalib audio driver.
[AO SDL] Unable to open audio: No available audio device
Failed to initialize audio driver 'sdl:aalib'
Could not open/initialize audio device -> no sound.
Audio: no sound
Video: no video


Exiting... (End of file)


the aplay -l seems ok

/home/linaro# aplay -l
**** List of PLAYBACK Hardware Devices ****
card 0: sunxicodec [sunxi-CODEC], device 0: M1 PCM [sunxi PCM]
  Subdevices: 1/1
  Subdevice #0: subdevice #0

Thanks in advance for your feedback.

Manu

magno

  • Guest
Re: Cubiuntu 0.6 for A20 with 3.4.75+ kernel
« Reply #24 on: January 12, 2014, 12:07:59 pm »
Pat,
Catalog updated!
Check http://cubieboard.cmabreu.com.br/ page 2 for SDCARD images.

« Last Edit: January 12, 2014, 12:13:52 pm by magno »

Offline patwood

  • Linux geek
  • Global Moderator
  • Hero Member
  • *****
  • Posts: 1660
  • Karma: +129/-0
    • View Profile
Re: Cubiuntu 0.6 for A20 with 3.4.75+ kernel
« Reply #25 on: January 12, 2014, 11:32:20 pm »
Dear All,

Is there anything to do to activate the audio on the standard line output ?
Neitheir aplay not mplayer manage to initialize audio

the aplay -l seems ok

/home/linaro# aplay -l
**** List of PLAYBACK Hardware Devices ****
card 0: sunxicodec [sunxi-CODEC], device 0: M1 PCM [sunxi PCM]
  Subdevices: 1/1
  Subdevice #0: subdevice #0

Thanks in advance for your feedback.

Manu

Looks like you need to change the default card from 1 to 0 in /etc/asound.conf.

hh

  • Guest
Re: Cubiuntu 0.6 for A20 with 3.4.75+ kernel
« Reply #26 on: January 13, 2014, 06:15:16 am »
Thank you very much for this A20 image.

Capturing Audio with the onboard codec does not seem to be possible:

root@linaro-ubuntu-desktop:~# arecord -l

**** List of CAPTURE Hardware Devices ****

root@linaro-ubuntu-desktop:~#


Do I need to insmod something?


hh

  • Guest
Re: Cubiuntu 0.6 for A20 with 3.4.75+ kernel
« Reply #27 on: January 13, 2014, 11:11:21 am »
As an alternative I tried out the latest cubian image for the A20 board and this distribution lets me use the audio capture device:

Code: [Select]
cubie@Cubian:~$ uname -a
Linux Cubian 3.4.67+ #4 SMP PREEMPT Wed Nov 6 08:31:09 CST 2013 armv7l GNU/Linux
cubie@Cubian:~$ arecord -l
**** List of CAPTURE Hardware Devices ****
card 0: sunxicodec [sunxi-CODEC], device 0: M1 PCM [sunxi PCM]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
cubie@Cubian:~$

However, jackd2 in cubian crashes with "bus error", whereas jackd2 in ubuntu-linaro works without crashing, at least for playback.

(I also tried installing the linaro packages in cubian - still "bus error")

I would like to use analogue audio input and output simultaneously with jackd, building a sound processing device with the cubieboard.

Offline Jojo

  • Developer
  • Full Member
  • ***
  • Posts: 190
  • Karma: +13/-0
  • Cubieboard 2 - A20, aRUNTU v1.666
    • View Profile
Re: Cubiuntu 0.6 for A20 with 3.4.75+ kernel
« Reply #28 on: January 15, 2014, 06:58:38 am »
Hi and thanks alot for the upload :) .

Finally. after 5 nerverending weeks of waiting, I have received my CB2 ! I installed your (patwoods) distro and everything worked fine :) .

Thumbs up!

I have problems with three things:
1. I don't get flash player working. On the site "supermechs.com" it says that I need flashplayer 11.1 or higher. I THINK I have installed it correctly, but how can I check that?!

2. Youtube does not work

3. HDMI sound does not work

Are there any ways to fix these things?

Thanks and greetings,
Jojo

Edit:
P.S.: I wrote this post with my CB2 via VNC :)
« Last Edit: January 15, 2014, 07:08:05 am by Jojo »
Don't think that anyone will take more pains for his answer, as you took for your question.

Offline Tokka

  • Developer
  • Full Member
  • ***
  • Posts: 193
  • Karma: +16/-0
    • View Profile
Re: Cubiuntu 0.6 for A20 with 3.4.75+ kernel
« Reply #29 on: January 15, 2014, 09:38:53 am »
Hi Jojo, i haven't cb2, but i hope is the same as cubiuntu for cb1 :P

flash: try to install (if not present) gnash, with apt-get install browser-plugin-gnash, but youtube works only at 240p, and may be you need firefox;

hdmi audio: if you are on vnc way, and no hdmi cable connected, hdmi audio don't works. If cable is connected, try to open pulse audio volume control, and set the green flag on hdmi output, this should solve

Regards
Tk
CB1 (A10) - Qbee-X_TMC