November 20, 2019, 03:45:02 am

News:

Have you visited the Allwinner Chipset wiki? - http://linux-sunxi.org/


Buster, Xenial and Bionic - updated 6.7.2019

Started by slovenia, December 24, 2013, 03:23:11 pm

Previous topic - Next topic

slovenia

v5.30 / 14.06.2017

- mainline kernel updated to 4.11
- mainline u-boot updated to v2017.05
- Firefox was replaced with Chromium (desktop images)
- sunxi mainline configuration: added Device Tree overlays support (new images only)
- sunxi mainline configuration: added armbian-add-overlay helper for compiling and activating DT overlays (new images only)
- log2ram: fixed saving /var/log contents on shutdown
- new hardware support (stable/supported images): Xunlong Orange Pi Zero Plus 2 (H3), ASUS TinkerBoard, MiQi
- reworked package updates MOTD script to speed up the login process
- added config file /etc/default/armbian-motd for disabling MOTD components
- added armbian-config dialog-based configuration program (WIP)
- Banana Pi M2: fixed HDMI video output
- Clearfog: adjusted temperature readout
- i.MX6 mainline: enabled support for HDMI audio and PCIe bus
Debian and Ubuntu images with kernel 3.4.110, 4.3.3, 4.4
http://www.armbian.com

slovenia

Debian and Ubuntu images with kernel 3.4.110, 4.3.3, 4.4
http://www.armbian.com

Foorez

I have problem with amule. Amule crash the system after 30/60 days
Linux cubietruck 3.4.113-sun7i #23 SMP PREEMPT Wed Jun 14 23:57:45 CEST 2017 armv7l GNU/Linux
aMuleD 2.3.2 compiled with wxBase(GTK2) v3.0.2 and Boost 1.55 (OS: Linux)
$ cat /etc/debian_version
8.9
I want upgrade or install debian stretch on cubietruck v.3.

please help me

Foorez

$ cat etc/armbian.txt | head -n 4
--------------------------------------------------------------------------------
Title:         Armbian 5.23 Cubietruck Debian jessie default
Kernel:         Linux 3.4.112
Build date:      23.10.2016

$ sudo cat /var/log/kern.log | egrep "Linux version"
Sep 15 18:17:12 localhost kernel: [    0.000000] Linux version 3.4.113-sun7i (root@devel) (gcc version 5.4.0 20160609 (Ubuntu/Linaro 5.4.0-6ubuntu1~16.04.4) ) #23 SMP PREEMPT Wed Jun 14 23:57:45 CEST 2017

my problem is this , i have a version kernel don't upgrade
#sudo apt-get dist-upgrade
after i have armbian 5.31and not 5.25 why ??
i downgrade armbian and linux kernel to version 5.25
# apt-get install armbian-tools-jessie=5.25
and downgrade to 5.25 this
linux-image-sun7i linux-jessie-root-cubietruck linux-headers-sun7i linux-base linux-u-boot-cubietruck-default sunxi-tools hostapd

Coolzero1982

hello, I've been using your image on the cubietruck for a while, and updated it to Debian Stretch 9.3 today, but the kernel has not been updated and is still 3.4.104-sunxi, how can I upgrade the kernel to a current version 4. Update X? Thank you


Gesendet von iPhone mit Tapatalk

slovenia

Quote from: Coolzero1982 on January 07, 2018, 03:47:55 pm
hello, I've been using your image on the cubietruck for a while, and updated it to Debian Stretch 9.3 today, but the kernel has not been updated and is still 3.4.104-sunxi, how can I upgrade the kernel to a current version 4. Update X? Thank you


Gesendet von iPhone mit Tapatalk


You need to update kernel separately. First, remove all packages and install new, here are the names:

https://www.armbian.com/kernel/

Since you are upgrading from a very old build, prepare for the worst case. And remember that NAND is not supported under modern kernel. Also Debian Stretch is not working properly on the old kernel.
Debian and Ubuntu images with kernel 3.4.110, 4.3.3, 4.4
http://www.armbian.com



slovenia

Debian and Ubuntu images with kernel 3.4.110, 4.3.3, 4.4
http://www.armbian.com

slovenia

Debian and Ubuntu images with kernel 3.4.110, 4.3.3, 4.4
http://www.armbian.com

slovenia

Debian and Ubuntu images with kernel 3.4.110, 4.3.3, 4.4
http://www.armbian.com