November 19, 2019, 05:07:54 am

News:

Have you visited the Allwinner Chipset wiki? - http://linux-sunxi.org/


Buster, Xenial and Bionic - updated 6.7.2019

Started by slovenia, December 24, 2013, 03:23:11 pm

Previous topic - Next topic

jedie

I downloaded 1.9 today and run it.

OpenSSL 1.0.1e-2+deb7u is installed. On http://heartbleed.com/ it's listed under "potentially vulnerable OpenSSL version"...

How to update?

jedie

now i have used the SATA install. SD-Card is inserting for booting. But didn't loop. it's in a boot-loop. But i didn't see anything on the Monitor (Maybe the TFT takes to mutch time for sync and display anything)

What can i do to get more information about what's going wrong?

Maybe change boot settings and increase verbosity?

slovenia

Quote from: jedie on April 30, 2014, 08:42:23 am
I downloaded 1.9 today and run it.

OpenSSL 1.0.1e-2+deb7u is installed. On http://heartbleed.com/ it's listed under "potentially vulnerable OpenSSL version"...

How to update?


Execute this:

apt-get update
apt-get upgrade

Debian and Ubuntu images with kernel 3.4.110, 4.3.3, 4.4
http://www.armbian.com

jedie

OpenSSL is now: 1.0.1e-2+deb7u7
Is it vulnerable or patched?

My SATA Problem: Don't know why, but the script hasn't created a useable HD...
I now just mount the SD-Card and the SATA HD on a other debian an clone the rootfs vom SD Card to HD and resize it (With GParted)...

Now booting from HD works. Great!

jedie

Some questions:

* How to enable log output at boot?
* Is it possible to switch to debian jessie (Just edit source.list and dist-upgrade) for getting MATE desktop (see also: http://www.cubieforums.com/index.php?topic=2462 )



slovenia

QuoteOpenSSL is now: 1.0.1e-2+deb7u7


This version should be O.K. You can try out with some on-line tester.
https://www.debian.org/security/2014/dsa-2908

QuoteHow to enable log output at boot?


edit /boot/uEnv.ct and change
console=ttyS0,115200
to
console=tty0

QuoteIs it possible to switch to debian jessie


yes. Don't know about MATE desktop ... probably it is possible.

QuoteDon't know why, but the script hasn't created a useable HD...


Install scripts just copy(rsync) root file-system from SD to SATA partition which has to be prepared and adjusts boot parameter. Gr8 that you manage on your own.
Debian and Ubuntu images with kernel 3.4.110, 4.3.3, 4.4
http://www.armbian.com

jedie

Quote from: slovenia on April 30, 2014, 01:10:53 pm
QuoteOpenSSL is now: 1.0.1e-2+deb7u7


This version should be O.K. You can try out with some on-line tester.
https://www.debian.org/security/2014/dsa-2908

Thanks! On the debian page is this:
QuoteFor the stable distribution (wheezy), these problems have been fixed in version 1.0.1e-2+deb7u7.

So it looks good ;)

Quote from: slovenia on April 30, 2014, 01:10:53 pm
QuoteHow to enable log output at boot?


edit /boot/uEnv.ct and change
console=ttyS0,115200
to
console=tty0

Ah, ok. i will try...

Btw. is there a way to setup a netconsole to troubleshoot uBoot without a serial cable?
I know this from the doozan dockstart work, see: http://forum.doozan.com/read.php?3,14,14


Quote from: slovenia on April 30, 2014, 01:10:53 pm
QuoteIs it possible to switch to debian jessie


yes. Don't know about MATE desktop ... probably it is possible.

MATE desktop is available in jessie, if i have the time, i will try.

Quote from: slovenia on April 30, 2014, 01:10:53 pm
QuoteDon't know why, but the script hasn't created a useable HD...


Install scripts just copy(rsync) root file-system from SD to SATA partition which has to be prepared and adjusts boot parameter. Gr8 that you manage on your own.

Ah ok. Think that's it. I doesn't know that i have to partition the disk before ;)

smotritel89

Hi!

Try compile ASIX module.   build-essential install.

make
make -C /lib/modules/3.4.79-sun7i+/build SUBDIRS=/root/asix modules
make: *** /lib/modules/3.4.79-sun7i+/build: No such file or directory.  Stop.
make: *** [default] Error 2

how can I solve this problem?

slovenia

Quote from: smotritel89 on May 01, 2014, 01:52:58 am
Hi!

Try compile ASIX module.   build-essential install.

make
make -C /lib/modules/3.4.79-sun7i+/build SUBDIRS=/root/asix modules
make: *** /lib/modules/3.4.79-sun7i+/build: No such file or directory.  Stop.
make: *** [default] Error 2

how can I solve this problem?


asix module is already compiled within kernel

modprobe asix

General instructions:
http://stackoverflow.com/questions/11771818/how-to-make-existing-linux-kernel-module-driver-after-modifying-the-driver-sou
http://www.google.com/search?q=how+to+compile+linux+kernel+modules
Debian and Ubuntu images with kernel 3.4.110, 4.3.3, 4.4
http://www.armbian.com

slovenia

QuoteBtw. is there a way to setup a netconsole to troubleshoot uBoot without a serial cable?


Not that I am aware of it.

Ah ok. Think that's it. I doesn't know that i have to partition the disk before

Scripts were initially meant for personal usage and are slowly developing towards "user friendly mode".  ::)
Debian and Ubuntu images with kernel 3.4.110, 4.3.3, 4.4
http://www.armbian.com

quickpass

I have a few questions, can you please help answer?

1) Can I install Plex Media Server on this image?
2) The same image will work for both NAND and SD card?
3) If I want to flash to NAND, do you have an instruction to do that?

Thanks,
QP

slovenia

Quote from: quickpass on May 01, 2014, 06:21:51 pm
I have a few questions, can you please help answer?

1) Can I install Plex Media Server on this image?
2) The same image will work for both NAND and SD card?
3) If I want to flash to NAND, do you have an instruction to do that?

Thanks,
QP


1. I have no experience with Plex Media Server but if it works on RasPI than it is possible to be installed on Cubieboard. My image included. Beware that if you want to run a media center (XBMC or similar) you will have troubles playing HD videos since drivers are not fully developed yet.

2 and 3. You can't flash this image directly to NAND. You have to create SD card, boot and transfer/mirror/rsync the content to NAND. Utility (installer) is included ... workaround (if trouble occurred) is described in first post.
Debian and Ubuntu images with kernel 3.4.110, 4.3.3, 4.4
http://www.armbian.com

exciter

Quote from: pattinik on April 30, 2014, 07:52:29 am
Quote from: slovenia on April 30, 2014, 02:22:41 am
login as root than execute:

cd /
wget http://cubie.nobrainz.de/downloads/update-1.8-1.9.tgz
tar xvfz update-1.8-1.9.tgz



Tnx! I did it, but now I'm having some issues with the autostart of openvpn service. In fact it stopped to start automatically at the reboot. I don't know why.   :-\

EDIT:
Solved with updating rc.d
update-rc.d openvpn enable


Hello,

got problems with openvpn here too after update to 1.9 via:
cd /
wget http://cubie.nobrainz.de/downloads/update-1.8-1.9.tgz
tar xvfz update-1.8-1.9.tgz


I can't restart the openvpn service, got the error that virtual adapter can't start...
Have reinstalled openvpn, and while configureing "sudo iptables -t nat -A POSTROUTING -s 10.0.0.0/8 ! -d 10.0.0.0/8 -o eth0 -j MASQUERADE"I got this error:

Error:

"ERROR: could not insert 'ip_tables': Invalid argument
iptables v1.4.14: can't initialize iptables table `nat': Table does not exist (do you need to insmod?)"


Igor wrote already on his blog, that he have no problems with clean 1.9 image, but I can't test it atm, cause CT is not here, where I am atm;)

So some ideas to get this CT with upgraded 1.9 version get working?

interrobang

Hello,
is somebody able to compile this driver on cubietruck?

AX88179 -- USB3.0 to 10/100/1000M Gigabit Ethernet Controller
http://www.asix.com.tw/products.php?op=pItemdetail&PItemID=131;71;112

If i extract and run "make" a message like in this post appear:
http://www.cubieforums.com/index.php?topic=1275.msg16005#msg16005

If i extract the missing (!?) kernel source to /home/cubie/image/linux-sunxi/ a message like this appear:

root@cubie:/home/AX88179_178A_LINUX_DRIVER_v1.10.0_SOURCE# make
make -C /lib/modules/3.4.79-sun7i+/build SUBDIRS=/home/AX88179_178A_LINUX_DRIVER_v1.10.0_SOURCE modules
make[1]: Entering directory `/home/cubie/image/linux-sunxi'

  ERROR: Kernel configuration is invalid.
         include/generated/autoconf.h or include/config/auto.conf are missing.
         Run 'make oldconfig && make prepare' on kernel src to fix it.


  WARNING: Symbol version dump /home/cubie/image/linux-sunxi/Module.symvers
           is missing; modules will have no dependencies and modversions.

  CC [M]  /home/AX88179_178A_LINUX_DRIVER_v1.10.0_SOURCE/ax88179_178a.o
In file included from <command-line>:0:0:
/home/cubie/image/linux-sunxi/include/linux/kconfig.h:4:32: fatal error: generated/autoconf.h: No such file or directory
compilation terminated.
make[2]: *** [/home/AX88179_178A_LINUX_DRIVER_v1.10.0_SOURCE/ax88179_178a.o] Error 1
make[1]: *** [_module_/home/AX88179_178A_LINUX_DRIVER_v1.10.0_SOURCE] Error 2
make[1]: Leaving directory `/home/cubie/image/linux-sunxi'
make: *** [default] Error 2


Thank you!

AndiBcool

Yes this compiling is a science on its own i guess.
Someone tryed to help me in this Post:
http://www.cubieforums.com/index.php?topic=2427.msg15944

Havent had time to try but he said it works for him.

However he and slovenia said they did booth compile successfull,
but the driver ( in my case ) didnt work.