Author Topic: Buster, Xenial and Bionic - updated 6.7.2019  (Read 733922 times)

Offline slovenia

  • Hero Member
  • *****
  • Posts: 511
  • Karma: +47/-0
    • View Profile
Re: Wheezy server for SD, SATA or NAND with hotspot - update 8.4.2014
« Reply #390 on: April 23, 2014, 11:38:21 am »
One thing however came up while building this, that is VLAN support of the Cubietruck Gbit Ethernet NIC is really poor.  It seems to work when you configure it, however once you measure the throughput it is about 5-10% of the throughput without VLAN tagging.

There is some recent patch (disabling debug) and I recompiled kernel with it. No idea if it really helps but you are welcome to test if you like.

http://www.mediafire.com/download/nk665vs5on0ho3s/kernel-3.4.79.vlanpatch.tgz
Debian and Ubuntu images with kernel 3.4.110, 4.3.3, 4.4
http://www.armbian.com

Heisenberg

  • Guest
Re: Wheezy server for SD, SATA or NAND with hotspot - update 8.4.2014
« Reply #391 on: April 24, 2014, 06:47:46 am »
I am testing your image with a 7800mAh li-ion battery now.

I have tried editing /sys/class/power_supply/battery/energy_full_design but it seems to be read-only.

Where do I set the battery capacity? Thank you!

Offline slovenia

  • Hero Member
  • *****
  • Posts: 511
  • Karma: +47/-0
    • View Profile
Re: Wheezy server for SD, SATA or NAND with hotspot - update 8.4.2014
« Reply #392 on: April 24, 2014, 07:29:27 am »
I am testing your image with a 7800mAh li-ion battery now.

I have tried editing /sys/class/power_supply/battery/energy_full_design but it seems to be read-only.

Where do I set the battery capacity? Thank you!

Theory: you can set those parameters in script files ... /boot/ct-vga.fex or /boot/ct-hdmi.fex You need to convert bin2fex , edit and than fex2bin back.

Kernel support for batteries is very basic (non existing?) ... i don't have battery but already heard complains ... It's related to all images and might be better in new (currently development) kernel since there are some changes in those areas. I was unsuccessfully trying to brought (related) functionality to current kernel  :(
Debian and Ubuntu images with kernel 3.4.110, 4.3.3, 4.4
http://www.armbian.com

Heisenberg

  • Guest
Re: Wheezy server for SD, SATA or NAND with hotspot - update 8.4.2014
« Reply #393 on: April 24, 2014, 09:47:16 am »
I found a setting called pmu_battery_cap in ct-hdmi.fex (aka ct-vga.fex or script.fex) and edited that to set the battery capacity (default 2100mAh).

I will report back on my findings relating to battery support for your image and Cubian.

Results so far:
  • Battery capacity can be set correctly, in mAh.
    (see above)
  • Battery voltage reading is correct, in microvolts.
    /sys/class/power_supply/battery/voltage_now
  • Battery charge status is correct, either Discharging or Charging.
    /sys/class/power_supply/battery/status

Problems so far:
  • Poweroff fails when battery and dc power is connected. The board simply reboots — so the battery can not be charged while the board is off. I'm not sure if it's meant to work like that. Poweroff works fine when either power or battery is connected.
« Last Edit: April 24, 2014, 11:01:11 am by Heisenberg »

Offline suchende

  • Newbie
  • *
  • Posts: 8
  • Karma: +0/-0
    • View Profile
Re: Wheezy server for SD, SATA or NAND with hotspot - update 8.4.2014
« Reply #394 on: April 24, 2014, 01:25:35 pm »
I have got a problem with the main system. After a while the system doesn't respond (over lan). It seems to be a time span over 6 days. Unfortainely i didn't check, if the system would work on the terminal.
I didn't find anything intersting in the logs. Anyone who has got this problem too?

Offline slovenia

  • Hero Member
  • *****
  • Posts: 511
  • Karma: +47/-0
    • View Profile
Re: Wheezy server for SD, SATA or NAND with hotspot - update 8.4.2014
« Reply #395 on: April 25, 2014, 05:11:14 am »
I have got a problem with the main system. After a while the system doesn't respond (over lan). It seems to be a time span over 6 days. Unfortainely i didn't check, if the system would work on the terminal.
I didn't find anything intersting in the logs. Anyone who has got this problem too?

I never experienced system hang. I remember once that one USB device hanged but have no ideas where is this related to since at that time I didn't have time to investigate. My longest uptime is 18 days because I check new image builds and have to shut-down.

What can be? Power supply unit? Cubitruck rev. B issue? Some strange USB device? Overclock is default in latest image - set back to defaults. It's also important to know if whole system hangs or just Ethernet which driver is also not well polished yet.
Debian and Ubuntu images with kernel 3.4.110, 4.3.3, 4.4
http://www.armbian.com

Offline marcelpo

  • Newbie
  • *
  • Posts: 13
  • Karma: +0/-0
    • View Profile
Re: Wheezy server for SD, SATA or NAND with hotspot - update 8.4.2014
« Reply #396 on: April 25, 2014, 07:13:12 am »
One thing however came up while building this, that is VLAN support of the Cubietruck Gbit Ethernet NIC is really poor.  It seems to work when you configure it, however once you measure the throughput it is about 5-10% of the throughput without VLAN tagging.

There is some recent patch (disabling debug) and I recompiled kernel with it. No idea if it really helps but you are welcome to test if you like.

http://www.mediafire.com/download/nk665vs5on0ho3s/kernel-3.4.79.vlanpatch.tgz


Ah cool ! I will definitely give this a try, and will let you know !! 


Offline marcelpo

  • Newbie
  • *
  • Posts: 13
  • Karma: +0/-0
    • View Profile
Re: Wheezy server for SD, SATA or NAND with hotspot - update 8.4.2014
« Reply #397 on: April 26, 2014, 12:53:10 pm »
One thing however came up while building this, that is VLAN support of the Cubietruck Gbit Ethernet NIC is really poor.  It seems to work when you configure it, however once you measure the throughput it is about 5-10% of the throughput without VLAN tagging.

There is some recent patch (disabling debug) and I recompiled kernel with it. No idea if it really helps but you are welcome to test if you like.

http://www.mediafire.com/download/nk665vs5on0ho3s/kernel-3.4.79.vlanpatch.tgz


Ah cool ! I will definitely give this a try, and will let you know !!

OK this is looking good !  First I tried the kernel you uploaded, but meanwhile I discovered that things were evolving quickly around this issue, and in the end I recompiled the kernel with a clone of your latest GIT

And the results are very promising.  Doing a multiple stream test with iperf I easily achieve 650-700 Mbits output with VLAN tagging active.  An unexpected surprise was also that the CPU temperature is about 5 degrees cooler in average than before this fix.

So, I decided to revert my cluster back to VLAN based setup because of this (I have to use both private and public addresses, so not to mess things up too much I'd like to keep them in separate VLAN's)
it looks like everything is just fine now :)

Offline Sloop

  • Jr. Member
  • **
  • Posts: 55
  • Karma: +2/-0
    • View Profile
Re: Wheezy server for SD, SATA or NAND with hotspot - update 8.4.2014
« Reply #398 on: April 27, 2014, 03:18:08 am »
Hi marcelpo. Could you tell us what and how exactly you did? I would be also interested in achieving better NIC throughput,because I also run a cluster with DRBD. Which kernel are you using at the moment?


Offline marcelpo

  • Newbie
  • *
  • Posts: 13
  • Karma: +0/-0
    • View Profile
Re: Wheezy server for SD, SATA or NAND with hotspot - update 8.4.2014
« Reply #399 on: April 27, 2014, 04:32:15 am »
Hi marcelpo. Could you tell us what and how exactly you did? I would be also interested in achieving better NIC throughput,because I also run a cluster with DRBD. Which kernel are you using at the moment?

The cluster is just based on IPVS, using IPIP tunnelling to the members (5 +1 Cubietrucks) and using ldirectord for keeping things healthy.
For this to work you can use the latest kernel that Slovenia makes available through his github (Just clone and compile the whole bunch and extract the kernel yourself)  This version already includes all the patches.
On the cluster members make sure to hide the tunnel interface using sysctl and the hidden function, and use arptables to make sure there is no leakage of ARP messages from the tunnel interface.

Using the cluster of 5+1 Cubietrucks, the total output per Cubietruck is about 650-700 Mbps.
But please realise this is just serving chunks of http traffic as a webserver and has nothing to do with the throughput of a single Cubie with any other application.




« Last Edit: April 27, 2014, 04:34:38 am by marcelpo »

Offline castalla

  • Developer
  • Full Member
  • ***
  • Posts: 106
  • Karma: +3/-0
    • View Profile
Re: Wheezy server for SD, SATA or NAND with hotspot - update 27.4.2014
« Reply #400 on: April 27, 2014, 06:46:22 pm »
I notice that the zip file contains a .raw file.

Do I simply write this to an SD card?   Is it the same as an .img file 

Ooops!  Read the install instructions and see how to install.

--------------------------

I note that there is a 20% overclock - how can I disable the overclocking?
« Last Edit: April 27, 2014, 08:01:43 pm by castalla »

Offline slovenia

  • Hero Member
  • *****
  • Posts: 511
  • Karma: +47/-0
    • View Profile
Re: Wheezy server for SD, SATA or NAND with hotspot - update 27.4.2014
« Reply #401 on: April 28, 2014, 01:19:47 am »
I notice that the zip file contains a .raw file.

Do I simply write this to an SD card?   Is it the same as an .img file 

Ooops!  Read the install instructions and see how to install.

--------------------------

I note that there is a 20% overclock - how can I disable the overclocking?

20% overclock is safe but if you really don't want this just edit:

/etc/init.d/cpufrequtils

and change from:
MAX_SPEED="1200000"
to:
MAX_SPEED="1010000"

than execute:

/etc/init.d/cpufrequtils restart
Debian and Ubuntu images with kernel 3.4.110, 4.3.3, 4.4
http://www.armbian.com

Offline pako

  • Jr. Member
  • **
  • Posts: 56
  • Karma: +2/-0
    • View Profile
Re: Wheezy server for SD, SATA or NAND with hotspot - update 27.4.2014
« Reply #402 on: April 28, 2014, 03:38:16 am »
Hello. My cubietruck sometimes stops working. I caught a moment in time when this happens. CFINTERACTIVE process loading  100% CPU and my cubietruck stops responding. If I understand correctly it CPU frequency process. how can I disable this?

Offline slovenia

  • Hero Member
  • *****
  • Posts: 511
  • Karma: +47/-0
    • View Profile
Re: Wheezy server for SD, SATA or NAND with hotspot - update 27.4.2014
« Reply #403 on: April 28, 2014, 03:53:22 am »
Hello. My cubietruck sometimes stops working. I caught a moment in time when this happens. CFINTERACTIVE process loading  100% CPU and my cubietruck stops responding. If I understand correctly it CPU frequency process. how can I disable this?

Try to down-clock to default frequency as described in previous post. I experienced instability only on higher over-clock (+1.2) which is expected.
Debian and Ubuntu images with kernel 3.4.110, 4.3.3, 4.4
http://www.armbian.com

Offline pattinik

  • Newbie
  • *
  • Posts: 14
  • Karma: +0/-0
    • View Profile
Re: Wheezy server for SD, SATA or NAND with hotspot - update 27.4.2014
« Reply #404 on: April 28, 2014, 07:42:07 am »
Hey, I noticed that you released a new version. Will you release also the update file, like in 1.8 version?

If not, which is the procedure to backup my system configurations (users,services and etc) and put all in the new version 1.9?

Like always, thank you for your job and your regular updates! 8)