December 11, 2019, 10:06:30 pm

News:

Have you visited the Allwinner Chipset wiki? - http://linux-sunxi.org/


Buster and Bionic - updated 21.11.2019

Started by slovenia, December 24, 2013, 03:23:11 pm

Previous topic - Next topic

marcelpo

Why did you use an old version of this image, and especially with kernel 3.19?  A lot of cubietruck specifiek options are not working in that kernel.

Use the latest one (see the first post in this thread) and preferably the variant based on Wheezy and with kernel 3.4.107

DerekTM

Thank you marcelpo.
I read the FAQ and it says:
QuoteWhich kernel to use?
For a headless server or light console / desktop operations mainline kernel (3.19.x and higher) is recommended.


Download page also says:
QuoteLatest 3.4.107 image have some stability issues. Build from sources or wait for update.


I don't need a cubietruck specific options, I need to build a router, so the networking performance has high-priority (but I have already investigated that PPPOE performance on this board is very low).

slovenia

For headless / server scenarios go for latest 4.x kernel ... I am currently doing long term stress tests but so far kernel 4.x looks stable.

For frequency scaling - it's build into kernel and it's work on some A20 images so I guess the problem must be in device tree. I am off for vacations so won't touch this for a while ...
Debian and Ubuntu images with kernel 3.4.110, 4.3.3, 4.4
http://www.armbian.com

DerekTM

Thank you slovenia.
I have tried "Cubietruck_Debian_3.9_wheezy_4.0.5" and "Cubietruck_Debian_4.0_wheezy_4.1.0" images and they are all stuck after "[OK] Enabling ramlog" line at first boot.

Cubietruck_Debian_3.9_jessie_4.0.5.zip also failes to boot:
QuoteWelcome to Debian GNU/Linux 8 (jessie)!
[ TIME ] Timed out waiting for device dev-ttyS0.device.
[DEPEND] Dependency failed for Serial Getty on ttyS0.



Is any working image with 4.x kernel available for Cubietruck?

slovenia

Strange, images are triple tested and they are working on my CT. People report this problem but I don't have access to hardware for next two weeks so can't help much. I saw (armbian.com) some guys are working to solve this mystery.

You can find one image with 4.1 on my forum. Again. Working without problems on my CT. It happened once that ETH was not recognized but power off/on solved this.

Wrote on mobile phone

Debian and Ubuntu images with kernel 3.4.110, 4.3.3, 4.4
http://www.armbian.com

sam

Can the mac address keep different   between  different cubieboard2 for this image  ?  it seem that the mac address from chipid is not perfert. It may cause a repeat mac address.

rahuldel


wsian

Quote from: rahuldel on July 13, 2015, 10:56:50 am
How can we enable the LED lights again?

I have the same issue. Even after editing
leds_trigger_1 = "none"  =>   leds_trigger_1 = "heartbeat"
and used fex2bin to convert to script.bin, the led still don't light up

Ireng

Hi to All!

Currently i am using 3.4.107-cubietruck #14 SMP PREEMPT Wed Apr 29 11:57:42 CEST 2015 armv7l GNU/Linux including a WLAN USB Adapter AWUS036AC from ALFA.
First question: Does anybody got this adapter to work with a cubietruck as a WLAN-AP?
Second question: If yes, what driver did you use for the successful implementation?

I want to use it as a 5GHZ (AC-standard) WLAN-AP!

Many thanks in advance.
Regards, Ireng

sanyigz

would this work with cubieboard2?

PS: As i see there are images for CB2 too!

"For a headless server or light console / desktop operations mainline kernel (3.19.x and higher) is recommended. If you need support for advanced graphics, audio, IR, NAND, ... you should stick with 3.4."

What is that "..."? And which audio can't be used with 4.x kernel? I need only the jack audio, so if hdmi audio which can't be used, that's no problem for me. (using cubieboard2 as headless java application server, fileserver with samba, minidlna, and mpd)


slovenia

@ sanyigz

If you need audio, get image 3.4.108 ... forget about 4.x

@AVI

Thanks! ;)
Debian and Ubuntu images with kernel 3.4.110, 4.3.3, 4.4
http://www.armbian.com

AVI

Unfortunately on video 720p and 1080p on mpv and mplayer2 with vdpau playing sound with delay

slovenia

Quote from: AVI on August 07, 2015, 03:30:18 am
Unfortunately on video 720p and 1080p on mpv and mplayer2 with vdpau playing sound with delay


Ahaa. OK. This is my first vdpau build. I have to admit that I haven't check the sound. I played few videos and they were OK.

I have no clues how to solve this ... yet.
Debian and Ubuntu images with kernel 3.4.110, 4.3.3, 4.4
http://www.armbian.com

phoenixinsilico

How do I install a login screen such as lightdm instead of autologin