August 10, 2020, 06:47:19 am


Have you visited the Allwinner Chipset wiki? -

plymouth main process killed by segv signal on cubieboard

Started by osousa, December 13, 2013, 02:33:20 pm

Previous topic - Next topic


Hi everybody!

This error really grinds my gears, as it is recurrent.

I have 4 cubieboards2 and i have tested them all with linaro distro.

What happens is, after some usage (Don't know the reason per se, probably after updating the kernel or only the plymouth itself?) when i try to boot them, i get something like:

ureadahead main process (485) terminated with status 5 ...
plymouth main process (53) killed by segv signal.

After some research i've removed these 2 errors but one still appears (the section delimited is wrong, can't recall the correct interval but you get the idea):

Write protecting the kernel text section c0008000 - c0952000

The fact is, this happens sooner or later in all of the cubieboards, wich makes them pretty unpractical to use :(

Thank you in advance for you help.


Any hints here?

I don't understand on how there aren't others with the same problem , as it happens to me with all my cubieboard2s.


What happens when you get this message?  Does the board lock up or reboot? Because this is a normal kernel information message. The kernel's executable area is marked as read-only after startup so it won't be inadvertently written over by errant code.


Hi patwood,

it does lock up, wich is a bummer as the only solution i've got so far is to flash the nand again, loosing everything.


This is an absolute downer for me. I will try to use Linaro Server in order to see if this problem does not ever happens again.


I've the same error message on my new cubietruck. System does not hang but I don't see desktop GUI at all. Any resolution?


"Write protecting the kernel text section c0008000 - c0952000" is not an error.  It is an info message.  The kernel text area is made read only at boot time so errant code can't overwrite it and crash the system.


could you help me take a look the log at:,1628.0.html
* dmesg-hdmi.txt
* hdmi.cap
at the end of that thread.

Basically, my new cubietruck only work 1st day I received for the default android image. 2nd day, power cycle cubietruck, the monitor only keep showing 'android' for ever.

I then installed Lubuntu desktop image on SD card, tried both VGA and HDMI monitor, the monitor does not give me GUI, but console UART port is working OK. I can ssh to the box without problem.

Any idea of what could be wrong, I saw plymouth process seg fault, that is the only thing makes me doubtful.