June 05, 2020, 05:32:57 pm


Have you visited the Allwinner Chipset wiki? - http://linux-sunxi.org/

UART Garbage?

Started by Deschain, November 30, 2013, 01:53:33 pm

Previous topic - Next topic


Hello there,

The main reason because I bought a cubieboard was that I was unable to install GNU/Linux in another SoC I have. It's one of those many Android TV boxes with an Amlogic AML8726-M (Meson-M1).

At first I though I would be easy because even though the seller (Airis) has no support, Amlogic have a site with some information, documentation and sources.

To the point, when I tried to access by the UART to the boot process (u-boot seems to be the standard in all these devices and boot from a SD card) it seemed that all I could read was garbage. Although I had Amlogic UART configuration I tried several more with no result. After some time I realize that most documentation from Amlogic is in Chinese so maybe it was no garbage but other charset (instead of latin-1 or the default in Putty) so I tried the well known UTF-8 (as I found to be the right charset for these cases) and then I could read some information, some Chinese chars but that was it all... I could no send any data to stop the boot process and access the u-boot "console"

So my question is if anybody has crossed this problem before or if anybody has any suggestion because I would like to mess up with this device


Just on important point: do you have ground connected as well as rx and tx?

Also, they might have locked down u-boot by disabling the autoboot countdown.


The UART port is kind of strange because it has Tx, Rx and two GND (will include picture). I tried almost all possible combinations just in case the labelling is wrong and of course with and without GND (each pin and both of them, maybe it needs a reference for both Tx and Rx, don't have the scheme). I could read some data with just one GND, Tx and Rx connected (as usual).

First I tried with an USB to UART TTL/COM adapter with the chip CP2102 which I have used before without any problem and when I bought the cubieboard I also tried with its adapter, but same problem...

And the auto boot countdown it's enable because it appears in the boot process (will include dump).

So basically I think that it may be a problem with Chinese charsets and I don't know how to figure this out...

P.S. Don't have JTAG or know Chinese to read the poor documentation they provide


Are you using the correct baudrate, parity, stop bits?


Quote from: diogoc on December 02, 2013, 04:24:05 am
Are you using the correct baudrate, parity, stop bits?

Yeap (according to the manufacturer)

Quote from: Deschain on November 30, 2013, 01:53:33 pm
Although I had Amlogic UART configuration


Hello there, got same problem.

Think thats garbage not chinese symbols, my aml8726-mx box hardly software broken.
Thats like firmware got garbage in uart config on board (or suplyer try to secure box). Same problem with non briket box.

Trying to do anything with that box, got 10 box fl200 thin client (Cortex-A9x2x1.5GHz, 1GB, 4GB, Mali400). Got no firmware, factory miss up all my emails. All firmware that i found broken, no usb burning luck, allways errors after write and boot usb_spl.bin with all libusb0 drivers, burning image 1.x and 2.x version same iusse. Uart cable show garbage at Amlogic default settings ( tryed BruteForce baud rate, bits, etc ... no luck ). Compile own openelec image for this aml8726-mx board, try with any boot sd cards no luck, all unbrick methods, 30+ almost same hardware stock firmwares. ( Ember, LibreElec, MXlinux ).

Tryed any aml_autoscript on boot sd. Without UART im blind, but got some garbage UART reports, thats show activity of box when try boot with sd cards with short cut pin 7-8 on chip when plug in power. Got m6 chip (WorldCup device) driver found in host Windows system when short nand chip pin 14-15 when plug usb cable. Stop garbage from UART and start again after i run usb_spl.bin thru update.exe or burning tools. Box got no reset button, swich or pins. Only 4x holes UART connector and 2x holes near ( dont know ??? but not reset ).

So that box hardware, form factor, price very good but software very insecure and week. ( closed sources firmware that store RDP passwords from my privates servers - bad idea. Dont know how many hidden functions got this firmware)

Any ideas ? Solution ?

Found some: https://www.fredericb.info/2016/10/amlogic-s905-soc-bypassing-not-so.html