Author Topic: JavaFX dosn't work  (Read 3293 times)

guenter

  • Guest
JavaFX dosn't work
« on: November 21, 2013, 12:58:47 pm »
I installed the newest Java 8 - and Java works very good.

If I start a JavaFX-program there is this exception:

eglGetDisplay returned EGL_NO_DISPLAYGraphics Device initialization failed for :  es2
Error initializing QuantumRenderer: no suitable pipeline found
java.lang.RuntimeException: java.lang.RuntimeException: Error initializing QuantumRenderer: no suitable pipeline found


The same program works by Raspberry PI. I use "Raspian" as OS (with LXDE and opengles accelerated). Hardware: Cubieboard 2 (A20).

What is the problem?

304bl

  • Guest
Re: JavaFX dosn't work
« Reply #1 on: December 01, 2013, 06:27:23 pm »
did you use the proper java-fx ?
i mean is the java-fx compatible for a10 or a20 , maybe you have to take a special version.

i got a similar problem with a java api on raspberry pi, i had to download a specific library for arm processor and put in into the installer. but now they provide version for arm , then check is oracle didnt already provide a special version a10/a20 processor