December 10, 2019, 01:38:23 pm

News:

Have you visited the Allwinner Chipset wiki? - http://linux-sunxi.org/


Trouble with HDMI CB v2 - need help

Started by daddoo, October 15, 2013, 10:37:56 pm

Previous topic - Next topic

daddoo

Hey all, firstly really good stuff going on in here! Thanks everyone for their contribution. since i'm a total Linux newbie.

I have a CubieBoard v2, came with a Chinese version of Android. I started using it, incorporating new apps from play store etc. all was well till I took the Linux expedition.

Firstly the CubieBoard was hooked with my TV (Samsung F Series) it was all fine ran @ 720p.

Next I install the Cubeez on a SD card, edit script.bin to choose 1080p, at first it kept on working then after a day or two stopped giving display not with Linux, even not with the android.

After panicking for a while and changing HDMI cables, I get success by connecting it to a Receiver that further connects to TV. Now both NAND boot and SD card boot both started to work again.

Later on I grab the "Cubiuntu0.6.5a-a20" and start using that with no issues (just screen wont come back from blank, screensaver would randomly kick in etc.) but all operational.

Now yesterday I upgraded the built-in Android with "sun7i_android_sugar-cubieboard2-8192cu" and run it at 720p kinda play with it for a while etc, and back on Linux again. Few hours back it has stopped giving HDMI display again. Not directly to TV not with the Receiver either.

I bring in a PC monitor, plug it in and I get a display for Linux but not for Android (Boots up fine). Now when I restart the Cubiuntu forcefully or soft restart, the display doesn't come back on, but if I unplug the HDMI cable and plug it in half way between the booting process I get the display..

Really stuck here, any ideas?

daddoo

October 18, 2013, 07:25:58 pm #1 Last Edit: October 18, 2013, 07:44:52 pm by daddoo
Hello? please someone at least share something to check if its config file error? or is it simply the hardware?

I only get a display on PC monitor, that is plugging in the HDMI cable when its booting process (when green starts to blink rapidly) on Cubiuntu0.6.5a-a20

No luck for onboard Android no display on Monitor or TV :(

:'(

Update: Working on Android as well, pluggin in the HDMI cable while its booting. I guess its the precise timing. Only on PC monitor no display on TV/or through receiver.

daddoo

October 23, 2013, 12:36:55 pm #2 Last Edit: October 23, 2013, 12:38:57 pm by daddoo
Update: I've tried 3 different Displays, 2 different power sources. Re-writing Default NAND Android  (with successful boots every time), Different SD Card images, on various SD cards. 3 different HDMI cables still no display not even 720p. Even tried editing the "uEnv.txt" etc.

Since my application requires a display (without pluggin it in while its booting), getting a remote session (which I don't know how to) isn't an option for me either.

To the Dust Bin!

Thanks everyone.

milkboy007

feel sorry for ya, but your CB is behaving uber weird.
sorry i didnt notice your post.  :P

soo let me get this straight, you are saying that your CB, both NAND boot and SD boot wont display anything on your tv/monitor on boot, and need to plug in the hdmi cable at a specific moment for the display to kick in, while using Cubiuntu.

may i ask what king of power supply u r using, and what is the rated power?
did you try other disto (i.e fedora)? if yes, does it have the same problem?

it would help if you can provide any log file.

daddoo

It is working fine with another HP monitor. Boots up fine, 720p and 1080p both working.

Just not with any TV (checked on Sony and Samsung) or Receiver (Pioneer). Both of these devices say "No Signal". Amazingly they worked flawlessly some time back.

The power supply is rated @ 5V ~ 2.5Amp (its a Tablet Charger)

Honestly i've given up on it. Someday when i'm able to find an image for it with remote session pre-configured i'll bring it to use again.

Thanks though for asking all in detail. and I have no idea how to pull the log file..

Azzy

@Dadoo. you are not alone. There is many others lost in the maze called Linux.

Myself, I am now, after umpteen attempts, on the verge of the  " To the dustbin" moment.
So much of the over-hyped features of these boards. With my 8 bit controllers I could get something done at least.

If You succeed in ironing out the bugs, please be so kind as to provide details of how you did it. The forum needs clarity, which is sadly lacking.

Hardware specs are not the only thing. Software is just as important and software INCLUDES instructions/ how-to's etc. if not more important.
I can see that the guys at Cubie are hard at work working on ever fresher releases of software. What they don't seem to get is that clear instructions are far more important. Not every one who is interested and buys a CB is an expert already.

If they want CB to grow they will have to take note of the newbies too.

Azzy

daddoo

Not working now on PC monitor either LOL!

I saw on Raspberry forum something about 5v rail for HDMI... Since there is no warranty for it I believe an "operation hardware" is in order.

Hope I don't Pooof the TV or monitor..