Author Topic: Power  (Read 2825 times)

Kaouthia

  • Guest
Power
« on: December 28, 2013, 08:34:48 am »
Hi guys,

So, my CubieBoard just arrived an hour or so ago, and I'm having a bit of a power issue.

I have a couple of 4 port USB charger here, which sports a pair of 1A sockets, and a pair of 2A sockets.  I've been using these the last few months with a couple of iPhones a couple of iPads, four 12000mAh USB batteries, Tascam DR-100, Raspberry Pi, and a bunch of other items.

I did buy my CubieBoard used, and while it came with a Mini-B USB cable, it did not come with a USB->DC Jack power cable.

When I use the USB Mini-B cable, from the same charger, it boots up just fine, no problems, but if I want to attach a SATA drive to it (which I do), this poses something of a problem.

Fortunately, the DC socket on the CubieBoard seems identical to that on my Tascam DR-100 (4mm plug, centre positive), so I grabbed my USB charging cable for that, and plugged it into my quad charger and the CubieBoard.

The power LED light comes on, and then I wait a few seconds for the other lights to come on, and nothing.  It just sits there.

I've also tried booting from both an iPhone charger, and one of my 12000mAh USB batteries.  With any device, it boots fine from the MiniB, but not from the USB->DC cable.

I would think "dodgy cable", but the power LED comes on (it's only sending 5v + ground, it's not like there's data going through it, and it seems to cope just fine on the DR-100), so the power does seem to be going through, it just doesn't want to boot when powered by the DC jack.

Any ideas?  Am I just missing something obvious?  Is there some switch I have to toggle to power it via the DC jack rather than USB?

Thanks guys.

Kaouthia

  • Guest
Re: Power
« Reply #1 on: December 28, 2013, 09:08:06 am »
So, a bit more experimenting.

I plugged in a 2.5" 160GB Hitachi SATA hard drive I had laying around.

When powered by the Mini-B USB cable, the drive just keeps trying to spin up, clicks, spin up, clicks, rinse, repeat.

When I have the DC jack plugged in, as above, nothing happens at all.

When I have both the Mini-B USB cable AND DC jack plugged in (each on its own 2A socket on my quad charger), the Android boots up, and the hard drive powers up just fine.

I've just tried the same thing with one of my 12000mAh batteries (Mini-B in 1A socket and DC jack in 2A socket) and it shows the same result.  Boots up and hard drive powers just fine.

I'm assuming this isn't the way it's supposed to work and that I should (in theory) be able to power everything just fine from the DC jack?

Are there any issues having power going into both the Mini-B and DC jack sockets at the same time? (it would be 2 cables from the same charger, or same battery, so would have a common ground).
« Last Edit: December 28, 2013, 09:10:35 am by Kaouthia »

Offline ahrovan

  • Full Member
  • ***
  • Posts: 120
  • Karma: +10/-0
    • View Profile
    • BirRoboticGroup
Re: Power
« Reply #2 on: February 12, 2014, 02:15:27 am »