Author Topic: cubian r7 released  (Read 5221 times)

Offline cubieplayer

  • Full Member
  • ***
  • Posts: 177
  • Karma: +22/-1
    • View Profile
cubian r7 released
« on: November 12, 2013, 05:32:49 am »
Main feature:
Auto expand rootfs to your fit your SD card at first boot

http://cubian.org/2013/11/12/cubian-r7-for-a10-and-r4-for-a20-released/
Cubian:http://cubian.org/ Cubian  Helpdesk:https://github.com/cubieplayer/Cubian/issues

ZS-Man

  • Guest
Re: cubian r7 released
« Reply #1 on: November 23, 2013, 09:16:46 am »
Hi, I have XBMC and VLC compiled on Cubian r7, but....

cvlc --demux ffmpeg --codec cedar --vout cedarfb --no-osd <media file>
vlc runs, HD video is playing smooth, but I cannot control playback by keyboard, nothing works... I must wait to video ends.

Same problem with XBMC. Program is started, I see main menu, but no keyboard/mouse input...
I see XBMC's cursor on one place and not moving, cursor of display manager (LXDE) is visible and moving,  but not interacting with XBMC...

Running from both terminal and X, still same problem.

Any solution? Thanks.
(and sorry for my english... :-\ )

Offline patwood

  • Linux geek
  • Global Moderator
  • Hero Member
  • *****
  • Posts: 1660
  • Karma: +129/-0
    • View Profile
Re: cubian r7 released
« Reply #2 on: November 23, 2013, 05:57:12 pm »
I saw someone who said the vlc curses interface was working.  I've used it with basic python bindings for playback control.  The on-screen controls don't work and are disabled (--no-osd) for that reason.

Offline pcklee123

  • Jr. Member
  • **
  • Posts: 53
  • Karma: +1/-0
    • View Profile
Re: cubian r7 released
« Reply #3 on: October 31, 2014, 07:30:00 pm »
you need to set permissions in udev rules.d
http://archlinuxarm.org/forum/viewtopic.php?f=31&t=5959

Hi, I have XBMC and VLC compiled on Cubian r7, but....

cvlc --demux ffmpeg --codec cedar --vout cedarfb --no-osd <media file>
vlc runs, HD video is playing smooth, but I cannot control playback by keyboard, nothing works... I must wait to video ends.

Same problem with XBMC. Program is started, I see main menu, but no keyboard/mouse input...
I see XBMC's cursor on one place and not moving, cursor of display manager (LXDE) is visible and moving,  but not interacting with XBMC...

Running from both terminal and X, still same problem.

Any solution? Thanks.
(and sorry for my english... :-\ )